Website Monitoring Degraded

Incident Report for conductor

Resolved

Performance across Conductor Website Monitoring is currently degraded. We are actively investigating.
Posted May 04, 2026 - 17:09 UTC

Investigating

Performance across Conductor Website Monitoring is currently degraded. We are actively investigating.
Posted May 04, 2026 - 15:31 UTC
This incident affected: Conductor Application and Conductor API.