CI - Keywords feature redirecting to Homepage

Incident Report for conductor

Resolved

Seems that for non-conductor users, clicking on the Keywords Feature redirects them to the accounts/Home page
Posted May 19, 2026 - 16:03 UTC

Investigating

Seems that for non-conductor users, clicking on the Keywords Feature redirects them to the accounts/Home page
Posted May 19, 2026 - 15:33 UTC
This incident affected: Conductor Application and Conductor API.